GLSA-200405-17 : Multiple vulnerabilities in metamail

High Nessus Plugin ID 14503


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200405-17 (Multiple vulnerabilities in metamail)

Ulf Harnhammar found two format string bugs and two buffer overflow bugs in Metamail.
Impact :

A remote attacker could send a malicious email message and execute arbitrary code with the rights of the process calling the Metamail program.
Workaround :

There is no known workaround at this time.


All users of Metamail should upgrade to the latest stable version:
# emerge sync # emerge -pv '>=net-mail/metamail-' # emerge '>=net-mail/metamail-'

See Also

Plugin Details

Severity: High

ID: 14503

File Name: gentoo_GLSA-200405-17.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:metamail, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/05/21

Vulnerability Publication Date: 2004/02/18

Reference Information

CVE: CVE-2004-0104, CVE-2004-0105

OSVDB: 3987, 3988, 4331

GLSA: 200405-17