GLSA-200405-16 : Multiple XSS Vulnerabilities in SquirrelMail

critical Nessus Plugin ID 14502


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200405-16 (Multiple XSS Vulnerabilities in SquirrelMail)

Several unspecified cross-site scripting (XSS) vulnerabilities and a well-hidden SQL injection vulnerability were found. An XSS attack allows an attacker to insert malicious code into a web-based application. SquirrelMail does not check for code when parsing variables received via the URL query string.
Impact :

One of the XSS vulnerabilities could be exploited by an attacker to steal cookie-based authentication credentials from the user's browser.
The SQL injection issue could potentially be used by an attacker to run arbitrary SQL commands inside the SquirrelMail database with privileges of the SquirrelMail database user.
Workaround :

There is no known workaround at this time. All users are advised to upgrade to version 1.4.3_rc1 or higher of SquirrelMail.


All SquirrelMail users should upgrade to the latest stable version:
# emerge sync # emerge -pv '>=mail-client/squirrelmail-1.4.3_rc1' # emerge '>=mail-client/squirrelmail-1.4.3_rc1'

See Also

Plugin Details

Severity: Critical

ID: 14502

File Name: gentoo_GLSA-200405-16.nasl

Version: 1.21

Type: local

Published: 8/30/2004

Updated: 1/6/2021

Risk Information


Risk Factor: Medium

Score: 5.8


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:squirrelmail, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/25/2004

Reference Information

CVE: CVE-2004-0519, CVE-2004-0521

BID: 10246

CERT-CC: CA-2000-02

GLSA: 200405-16