GLSA-200405-08 : Pound format string vulnerability

High Nessus Plugin ID 14494


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200405-08 (Pound format string vulnerability)

A format string flaw in the processing of syslog messages was discovered and corrected in Pound.
Impact :

This flaw may allow remote execution of arbitrary code with the rights of the Pound daemon process. By default, Gentoo uses the 'nobody' user to run the Pound daemon.
Workaround :

There is no known workaround at this time. All users are advised to upgrade to the latest available version of Pound.


All users of Pound should upgrade to the latest stable version:
# emerge sync # emerge -pv '>=www-servers/pound-1.6' # emerge '>=www-servers/pound-1.6'

See Also

Plugin Details

Severity: High

ID: 14494

File Name: gentoo_GLSA-200405-08.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pound, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/05/18

Vulnerability Publication Date: 2004/05/03

Reference Information

CVE: CVE-2004-2026

OSVDB: 5746

GLSA: 200405-08