IBM HTTP Server 8.0.0.0 <= 8.0.0.11 / 8.5.0.0 <= 8.5.5.6 (533837)

medium Nessus Plugin ID 144776

Synopsis

The remote web server is affected by a vulnerability.

Description

The version of IBM HTTP Server running on the remote host is affected by a vulnerability. The BN_GF2m_mod_inv function in crypto/bn/bn_gf2m.c in OpenSSL before 0.9.8s, 1.0.0 before 1.0.0e, 1.0.1 before 1.0.1n, and 1.0.2 before 1.0.2b does not properly handle ECParameters structures in which the curve is over a malformed binary polynomial field, which allows remote attackers to cause a denial of service (infinite loop) via a session that uses an Elliptic Curve algorithm, as demonstrated by an attack against a server that supports client authentication.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to IBM HTTP Server version 8.5.5.7, 8.0.0.12 or later. Alternatively, upgrade to the minimal fix pack level required by the interim fix and then apply Interim Fix PI44809.

See Also

https://www.ibm.com/support/pages/node/533837

Plugin Details

Severity: Medium

ID: 144776

File Name: ibm_http_server_533837.nasl

Version: 1.4

Type: local

Agent: unix

Family: Web Servers

Published: 1/6/2021

Updated: 4/11/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2015-1788

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:http_server

Required KB Items: installed_sw/IBM HTTP Server (IHS)

Exploit Ease: No known exploits are available

Patch Publication Date: 9/10/2015

Vulnerability Publication Date: 9/10/2015

Reference Information

CVE: CVE-2015-1788

BID: 75164