Oracle Linux 7 : ImageMagick (ELSA-2021-0024)

high Nessus Plugin ID 144748

Synopsis

The remote Oracle Linux host is missing a security update.

Description

The remote Oracle Linux 7 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2021-0024 advisory.

- ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not properly escaped/sanitized and it was therefore possible to inject additional shell commands via coders/pdf.c.
(CVE-2020-29599)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://linux.oracle.com/errata/ELSA-2021-0024.html

Plugin Details

Severity: High

ID: 144748

File Name: oraclelinux_ELSA-2021-0024.nasl

Version: 1.3

Type: local

Agent: unix

Published: 1/5/2021

Updated: 1/6/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-29599

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:oracle:linux:7, p-cpe:/a:oracle:linux:ImageMagick, p-cpe:/a:oracle:linux:imagemagick-c%2b%2b, p-cpe:/a:oracle:linux:imagemagick-c%2b%2b-devel, p-cpe:/a:oracle:linux:ImageMagick-devel, p-cpe:/a:oracle:linux:ImageMagick-doc, p-cpe:/a:oracle:linux:ImageMagick-perl

Required KB Items: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 1/5/2021

Vulnerability Publication Date: 12/7/2020

Reference Information

CVE: CVE-2020-29599