GLSA-200404-06 : Util-linux login may leak sensitive data

medium Nessus Plugin ID 14471

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200404-06 (Util-linux login may leak sensitive data)

In some situations the login program could leak sensitive data due to an incorrect usage of a reallocated pointer.
NOTE: Only users who have PAM support disabled on their systems (i.e. -PAM in their USE variable) will be affected by this vulnerability. By default, this USE flag is enabled on all architectures. Users with PAM support on their system receive login binaries as part of the pam-login package, which remains unaffected.
Impact :

A remote attacker may obtain sensitive data.
Workaround :

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Solution

All util-linux users should upgrade to version 2.12 or later:
# emerge sync # emerge -pv '>=sys-apps/util-linux-2.12' # emerge '>=sys-apps/util-linux-2.12'

See Also

https://security.gentoo.org/glsa/200404-06

Plugin Details

Severity: Medium

ID: 14471

File Name: gentoo_GLSA-200404-06.nasl

Version: 1.14

Type: local

Published: 8/30/2004

Updated: 1/6/2021

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:util-linux, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 4/7/2004

Reference Information

CVE: CVE-2004-0080

GLSA: 200404-06