IBM HTTP Server 8.5.0.0 <= 8.5.5.0 / 8.0.0.0 <= 8.0.0.6 / 7.0.0.0 <= 7.0.0.29 / 6.1.0.0 <= 6.1.0.45 (227047)

medium Nessus Plugin ID 144708
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 2.2

Synopsis

The remote web server is affected by a vulnerability.

Description

The version of IBM HTTP Server running on the remote host is affected by a vulnerability. mod_dav.c in the Apache HTTP Server before 2.2.25 does not properly determine whether DAV is enabled for a URI, which allows remote attackers to cause a denial of service (segmentation fault) via a MERGE request in which the URI is configured for handling by the mod_dav_svn module, but a certain href attribute in XML data refers to a non-DAV URI.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to IBM HTTP Server version 8.5.5.1, 8.0.0.7, 7.0.0.31, 6.1.0.47 or later. Alternatively, upgrade to the minimal fix pack level required by the interim fix and then apply Interim Fix PM89996.

See Also

https://www.ibm.com/support/pages/node/227047

Plugin Details

Severity: Medium

ID: 144708

File Name: ibm_http_server_227047.nasl

Version: 1.3

Type: local

Agent: unix

Family: Web Servers

Published: 1/4/2021

Updated: 1/25/2021

Dependencies: ibm_http_server_nix_installed.nbin

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 2.2

CVSS Score Source: CVE-2013-1896

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:http_server

Required KB Items: installed_sw/IBM HTTP Server (IHS), Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/26/2013

Vulnerability Publication Date: 8/26/2013

Reference Information

CVE: CVE-2013-1896

BID: 61129