GLSA-200404-04 : Multiple vulnerabilities in sysstat

Medium Nessus Plugin ID 14469


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200404-04 (Multiple vulnerabilities in sysstat)

There are two vulnerabilities in the way sysstat handles symlinks:
The isag utility, which displays sysstat data in a graphical format, creates a temporary file in an insecure manner.
Two scripts in the sysstat package, post and trigger, create temporary files in an insecure manner.
Impact :

Both vulnerabilities may allow an attacker to overwrite arbitrary files under the permissions of the user executing any of the affected utilities.
Workaround :

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.


Systat users should upgrade to version 4.2 or later:
# emerge sync # emerge -pv '>=app-admin/sysstat-5.0.2' # emerge '>=app-admin/sysstat-5.0.2'

See Also

Plugin Details

Severity: Medium

ID: 14469

File Name: gentoo_GLSA-200404-04.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:sysstat, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list, Host/Gentoo/arch

Patch Publication Date: 2004/04/06

Reference Information

CVE: CVE-2004-0107, CVE-2004-0108

GLSA: 200404-04