GLSA-200403-14 : Multiple Security Vulnerabilities in Monit

Critical Nessus Plugin ID 14465


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200403-14 (Multiple Security Vulnerabilities in Monit)

A denial of service may occur due to Monit not sanitizing remotely supplied HTTP parameters before passing them to memory allocation functions. This could allow an attacker to cause an unexpected condition that could lead to the Monit daemon crashing.
An overly long http request method may cause a buffer overflow due to Monit performing insufficient bounds checking when handling HTTP requests.
Impact :

An attacker may crash the Monit daemon to create a denial of service condition or cause a buffer overflow that would allow arbitrary code to be executed with root privileges.
Workaround :

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.


Monit users should upgrade to version 4.2 or later:
# emerge sync # emerge -pv '>=app-admin/monit-4.2' # emerge '>=app-admin/monit-4.2'

See Also

Plugin Details

Severity: Critical

ID: 14465

File Name: gentoo_GLSA-200403-14.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:monit, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/03/31

Reference Information

CVE: CVE-2003-1083, CVE-2003-1084

BID: 9098, 9099

GLSA: 200403-14