GLSA-200403-10 : Fetchmail 6.2.5 fixes a remote DoS

Medium Nessus Plugin ID 14461


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200403-10 (Fetchmail 6.2.5 fixes a remote DoS)

Fetchmail versions 6.2.4 and earlier can be crashed by sending a specially crafted email to a Fetchmail user. This problem occurs because Fetchmail does not properly allocate memory for long lines in an incoming email.
Impact :

Fetchmail users who receive a malicious email may have their Fetchmail program crash.
Workaround :

While a workaround is not currently known for this issue, all users are advised to upgrade to the latest version of Fetchmail.


Fetchmail users should upgrade to version 6.2.5 or later:
# emerge sync # emerge -pv '>=net-mail/fetchmail-6.2.5' # emerge '>=net-mail/fetchmail-6.2.5'

See Also

Plugin Details

Severity: Medium

ID: 14461

File Name: gentoo_GLSA-200403-10.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2004/08/30

Modified: 2016/10/05

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:fetchmail, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/03/30

Reference Information

CVE: CVE-2003-0792

GLSA: 200403-10