GLSA-200403-04 : Multiple security vulnerabilities in Apache 2

medium Nessus Plugin ID 14455
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200403-04 (Multiple security vulnerabilities in Apache 2)

Three vulnerabilities were found:
A memory leak in ssl_engine_io.c for mod_ssl in Apache 2.0.48 and below allows remote attackers to cause a denial of service attack via plain HTTP requests to the SSL port of an SSL-enabled server.
Apache fails to filter terminal escape sequences from error logs that begin with the ASCII (0x1B) sequence and are followed by a series of arguments. If a remote attacker could inject escape sequences into an Apache error log, the attacker could take advantages of weaknesses in various terminal emulators, launching attacks against remote users including further denial of service attacks, file modification, and the execution of arbitrary commands.
The Apache mod_disk_cache has been found to be vulnerable to a weakness that allows attackers to gain access to authentication credentials through the issue of caching HTTP hop-by-hop headers which would contain plaintext user passwords. There is no available resolution for this issue yet.
Impact :

No special privileges are required for these vulnerabilities. As a result, all users are recommended to upgrade their Apache installations.
Workaround :

There is no immediate workaround; a software upgrade is required. There is no workaround for the mod_disk_cache issue; users are recommended to disable the feature on their servers until a patched version is released.

Solution

Users are urged to upgrade to Apache 2.0.49:
# emerge sync # emerge -pv '>=www-servers/apache-2.0.49' # emerge '>=www-servers/apache-2.0.49' # ** IMPORTANT ** # If you are migrating from Apache 2.0.48-r1 or earlier versions, # it is important that the following directories are removed.
# The following commands should cause no data loss since these # are symbolic links.
# rm /etc/apache2/lib /etc/apache2/logs /etc/apache2/modules # rm /etc/apache2/modules # ** ** ** ** ** # ** ALSO NOTE ** # Users who use mod_disk_cache should edit their Apache # configuration and disable mod_disk_cache.

See Also

http://www.apache.org/dist/httpd/Announcement2.html

https://security.gentoo.org/glsa/200403-04

Plugin Details

Severity: Medium

ID: 14455

File Name: gentoo_GLSA-200403-04.nasl

Version: 1.13

Type: local

Published: 8/30/2004

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.3

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:H/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:apache, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 3/22/2004

Reference Information

CVE: CVE-2004-0113

BID: 9933

GLSA: 200403-04