GLSA-200403-01 : Libxml2 URI Parsing Buffer Overflow Vulnerabilities

High Nessus Plugin ID 14452


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200403-01 (Libxml2 URI Parsing Buffer Overflow Vulnerabilities)

Yuuichi Teranishi discovered a flaw in libxml2 versions prior to 2.6.6.
When the libxml2 library fetches a remote resource via FTP or HTTP, libxml2 uses parsing routines that can overflow a buffer caused by improper bounds checking if they are passed a URL longer than 4096 bytes.
Impact :

If an attacker is able to exploit an application using libxml2 that parses remote resources, then this flaw could be used to execute arbitrary code.
Workaround :

No workaround is available; users are urged to upgrade libxml2 to 2.6.6.


All users are recommended to upgrade their libxml2 installation:
# emerge sync # emerge -pv '>=dev-libs/libxml2-2.6.6' # emerge '>=dev-libs/libxml2-2.6.6'

See Also

Plugin Details

Severity: High

ID: 14452

File Name: gentoo_GLSA-200403-01.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libxml2, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/03/05

Reference Information

CVE: CVE-2004-0110

GLSA: 200403-01