ImageMagick < 6.9.11-40 / 7.x < 7.0.10-40 -authenticate Option Command Injection

high Nessus Plugin ID 144454

Synopsis

The remote Windows host has an application installed that is affected by a command injection vulnerability.

Description

The remote Windows host has a version of ImageMagick installed that is prior to 6.9.11-40 or 7.x prior to 7.0.10-4.
It is, therefore, affected by a command injection vulnerability via the -authenticate option.

Solution

Upgrade to ImageMagick version 6.9.11-40 or 7.0.10-40 or later.

Note that you may need to manually uninstall the vulnerable version from the system.

See Also

https://github.com/ImageMagick/ImageMagick/discussions/2851

http://www.nessus.org/u?7aef1910

Plugin Details

Severity: High

ID: 144454

File Name: imagemagick_7_0_10-40.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 12/18/2020

Updated: 6/3/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-29599

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Ease: No known exploits are available

Patch Publication Date: 11/21/2020

Vulnerability Publication Date: 11/21/2020

Reference Information

CVE: CVE-2020-29599

IAVB: 2020-B-0076-S