SolarWinds Orion Platform < 2020.2.1 HF2 Multiple Vulnerabilities

high Nessus Plugin ID 144449

Synopsis

An application running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the version of SolarWinds Orion Platform is prior to 2020.2.1 hot fix 2.
It is, therefore, affected by multiple vulnerabilities:

- A remote code execution vulnerability exists in the ExecuteVBScript method due to improper validation of a user-supplied string before using it to execute a system call. An authenticated, remote attacker can exploit this issue to execute arbitrary commands with SYSTEM privileges. (CVE-2020-14005)

- An SQL injection (SQLi) privilege escalation vulnerability exists in the WriteToFile method due to improper validation of a user-supplied string used to construct SQL queries. An authenticated, remote attacker can exploit this issue via SQLi to escalate privileges and reset the password for the Admin user.
(CVE-2020-27869)
- An information disclosure vulnerability exists in ExportToPDF.aspx due to lack of proper validation of a user-supplied path prior to it's use in file operations. An authenticated, remote attacker can exploit this issue, to disclose potentially sensitive information in the context of SYSTEM. (CVE-2020-27870)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to SolarWinds Orion Platform 2020.2.1 hot fix 2 or later.

See Also

http://www.nessus.org/u?ca60321d

https://www.zerodayinitiative.com/advisories/ZDI-21-064/

https://www.zerodayinitiative.com/advisories/ZDI-21-065/

https://www.zerodayinitiative.com/advisories/ZDI-21-066/

https://www.zerodayinitiative.com/advisories/ZDI-21-067/

Plugin Details

Severity: High

ID: 144449

File Name: solarwinds_orion_cve-2020-14005.nasl

Version: 1.6

Type: combined

Agent: windows

Family: Misc.

Published: 12/18/2020

Updated: 5/11/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2020-27871

VPR

Risk Factor: Medium

Score: 6.3

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:solarwinds:orion_network_performance_monitor, cpe:/a:solarwinds:orion_platform

Required KB Items: installed_sw/SolarWinds Orion Core

Exploit Ease: No known exploits are available

Patch Publication Date: 6/4/2020

Vulnerability Publication Date: 6/24/2020

Reference Information

CVE: CVE-2019-11358, CVE-2020-14005, CVE-2020-27869, CVE-2020-27870, CVE-2020-27871