GLSA-200401-04 : GAIM 0.75 Remote overflows

Medium Nessus Plugin ID 14444


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200401-04 (GAIM 0.75 Remote overflows)

Yahoo changed the authentication methods to their IM servers, rendering GAIM useless. The GAIM team released a rushed release solving this issue, however, at the same time a code audit revealed 12 new vulnerabilities.
Impact :

Due to the nature of instant messaging many of these bugs require man-in-the-middle attacks between the client and the server. But the underlying protocols are easy to implement and attacking ordinary TCP sessions is a fairly simple task. As a result, all users are advised to upgrade their GAIM installation.
Users of GAIM 0.74 or below are affected by 7 of the vulnerabilities and are encouraged to upgrade.
Users of GAIM 0.75 are affected by 11 of the vulnerabilities and are encouraged to upgrade to the patched version of GAIM offered by Gentoo.
Users of GAIM 0.75-r6 are only affected by 4 of the vulnerabilities, but are still urged to upgrade to maintain security.
Workaround :

There is no immediate workaround; a software upgrade is required.


All users are recommended to upgrade GAIM to 0.75-r7.
$> emerge sync $> emerge -pv '>=net-im/gaim-0.75-r7' $> emerge '>=net-im/gaim-0.75-r7'

See Also

Plugin Details

Severity: Medium

ID: 14444

File Name: gentoo_GLSA-200401-04.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gaim, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/01/26

Reference Information

GLSA: 200401-04