GLSA-200401-03 : Apache mod_python Denial of Service vulnerability
Low Nessus Plugin ID 14443
SynopsisThe remote Gentoo host is missing one or more security-related patches.
DescriptionThe remote host is affected by the vulnerability described in GLSA-200401-03 (Apache mod_python Denial of Service vulnerability)
The Apache Foundation has reported that mod_python may be prone to Denial of Service attacks when handling a malformed query. Mod_python 2.7.9 was released to fix the vulnerability, however, because the vulnerability has not been fully fixed, version 2.7.10 has been released.
Users of mod_python 3.0.4 are not affected by this vulnerability.
Although there are no known public exploits known for this exploit, users are recommended to upgrade mod_python to ensure the security of their infrastructure.
Mod_python 2.7.10 has been released to solve this issue; there is no immediate workaround.
SolutionAll users using mod_python 2.7.9 or below are recommended to update their mod_python installation:
$> emerge sync $> emerge -pv '>=www-apache/mod_python-2.7.10' $> emerge '>=www-apache/mod_python-2.7.10' $> /etc/init.d/apache restart