GLSA-200401-03 : Apache mod_python Denial of Service vulnerability

Low Nessus Plugin ID 14443


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200401-03 (Apache mod_python Denial of Service vulnerability)

The Apache Foundation has reported that mod_python may be prone to Denial of Service attacks when handling a malformed query. Mod_python 2.7.9 was released to fix the vulnerability, however, because the vulnerability has not been fully fixed, version 2.7.10 has been released.
Users of mod_python 3.0.4 are not affected by this vulnerability.
Impact :

Although there are no known public exploits known for this exploit, users are recommended to upgrade mod_python to ensure the security of their infrastructure.
Workaround :

Mod_python 2.7.10 has been released to solve this issue; there is no immediate workaround.


All users using mod_python 2.7.9 or below are recommended to update their mod_python installation:
$> emerge sync $> emerge -pv '>=www-apache/mod_python-2.7.10' $> emerge '>=www-apache/mod_python-2.7.10' $> /etc/init.d/apache restart

See Also

Plugin Details

Severity: Low

ID: 14443

File Name: gentoo_GLSA-200401-03.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2004/08/30

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Low

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mod_python, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2004/01/27

Reference Information

GLSA: 200401-03