IBM HTTP Server 8.5.0.0 <= 8.5.5.2 / 8.0.0.0 <= 8.0.0.8 / 7.0.0.0 <= 7.0.0.31 / 6.1.0.0 <= 6.1.0.47 / 6.0.0.0 <= 6.0.2.43 (509677)

high Nessus Plugin ID 144288

Synopsis

The remote web server is affected by a vulnerability.

Description

The version of IBM HTTP Server running on the remote host is affected by a vulnerability. The Reverse Proxy feature in IBM Global Security Kit (aka GSKit) in IBM Security Access Manager (ISAM) for Web 7.0 before 7.0.0-ISS-SAM-IF0006 and 8.0 before 8.0.0.3-ISS-WGA-IF0002 allows remote attackers to cause a denial of service (infinite loop) via crafted SSL messages.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to IBM HTTP Server version 8.5.5.3, 8.0.0.9, 7.0.0.33 or later. Alternatively, upgrade to the minimal fix pack level required by the interim fix and then apply Interim Fix PI17025.

See Also

https://www.ibm.com/support/pages/node/509677

Plugin Details

Severity: High

ID: 144288

File Name: ibm_http_server_509677.nasl

Version: 1.4

Type: local

Agent: unix

Family: Web Servers

Published: 12/15/2020

Updated: 4/11/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2014-0963

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.1

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:http_server

Required KB Items: installed_sw/IBM HTTP Server (IHS)

Exploit Ease: No known exploits are available

Patch Publication Date: 5/15/2014

Vulnerability Publication Date: 5/15/2014

Reference Information

CVE: CVE-2014-0963

BID: 67238