ignitionServer umode Command Global Operator Privilege Escalation

Medium Nessus Plugin ID 14388


The remote instant messaging server is affected by a privilege escalation issue.


The remote host is running a version of the IgnitionServer IRC service which might be vulnerable to a flaw that lets a remote attacker gain elevated privileges on the system. A local IRC operator can supply an unofficial command to the server to obtain elevated privileges and become a global IRC operator.


Upgrade to IgnitionServer 0.2.1-BRC1 or newer.

See Also


Plugin Details

Severity: Medium

ID: 14388

File Name: ircd_ignition_ircop_vuln.nasl

Version: $Revision: 1.15 $

Type: remote

Family: Misc.

Published: 2004/08/27

Modified: 2011/12/09

Dependencies: 11156, 11153, 17975

Risk Information

Risk Factor: Medium


Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2004/02/05

Reference Information

CVE: CVE-2004-2553

BID: 9783

OSVDB: 4121