RHEL 7 : mariadb-galera (RHSA-2020:5379)

critical Nessus Plugin ID 143607

Synopsis

The remote Red Hat host is missing a security update.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2020:5379 advisory.

- mariadb: Insufficient SST method name check leading to code injection in mysql-wsrep (CVE-2020-15180)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected mariadb-galera-common and / or mariadb-galera-server packages.

See Also

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/96.html

https://access.redhat.com/security/cve/CVE-2020-15180

https://access.redhat.com/errata/RHSA-2020:5379

https://bugzilla.redhat.com/1894919

Plugin Details

Severity: Critical

ID: 143607

File Name: redhat-RHSA-2020-5379.nasl

Version: 1.7

Type: local

Agent: unix

Published: 12/9/2020

Updated: 10/12/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-15180

CVSS v3

Risk Factor: Critical

Base Score: 9

Temporal Score: 7.8

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:mariadb-galera-common, p-cpe:/a:redhat:enterprise_linux:mariadb-galera-server

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/8/2020

Vulnerability Publication Date: 11/12/2020

Reference Information

CVE: CVE-2020-15180

RHSA: 2020:5379

CWE: 20, 96