Microsoft Edge (Chromium) < 87.0.664.57 Multiple Vulnerabilities

high Nessus Plugin ID 143588

Synopsis

The remote host has an web browser installed that is affected by multiple vulnerabilities.

Description

The version of Microsoft Edge installed on the remote Windows host is prior to 87.0.664.57. It is, therefore, affected by multiple vulnerabilities as referenced in the ADV200002-12-7-2020 advisory. Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Microsoft Edge version 87.0.664.57 or later.

See Also

http://www.nessus.org/u?083510ae

Plugin Details

Severity: High

ID: 143588

File Name: microsoft_edge_chromium_87_0_664_57.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 12/9/2020

Updated: 4/20/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2020-16039

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:edge

Required KB Items: installed_sw/Microsoft Edge (Chromium), SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/7/2020

Vulnerability Publication Date: 12/2/2020

Exploitable With

Metasploit (Google Chrome versions before 87.0.4280.88 integer overflow during SimplfiedLowering phase)

Reference Information

CVE: CVE-2020-16037, CVE-2020-16038, CVE-2020-16039, CVE-2020-16040, CVE-2020-16041, CVE-2020-16042

IAVA: 2020-A-0571-S