Ubuntu 16.04 LTS / 18.04 LTS : poppler vulnerabilities (USN-4646-1)

Medium Nessus Plugin ID 143266

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS / 18.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-4646-1 advisory.

- Poppler before 0.66.0 has an integer overflow in Parser::makeStream in Parser.cc. (CVE-2018-21009)

- The JPXStream::init function in Poppler 0.78.0 and earlier doesn't check for negative values of stream length, leading to an Integer Overflow, thereby making it possible to allocate a large memory chunk on the heap, with a size controlled by an attacker, as demonstrated by pdftocairo. (CVE-2019-9959)

- An issue was discovered in Poppler 0.74.0. There is a heap-based buffer over-read in the function PSOutputDev::checkPageSlice at PSOutputDev.cc. (CVE-2019-10871)

- In Xpdf 4.01.01, a heap-based buffer over-read could be triggered in strncpy from FoFiType1::parse in fofi/FoFiType1.cc because it does not ensure the source string has a valid length before making a fixed- length copy. It can, for example, be triggered by sending a crafted PDF document to the pdftotext tool. It allows an attacker to use a crafted pdf file to cause Denial of Service or an information leak, or possibly have unspecified other impact. (CVE-2019-13283)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4646-1

Plugin Details

Severity: Medium

ID: 143266

File Name: ubuntu_USN-4646-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2020/11/26

Updated: 2020/12/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.9

CVSS Score Source: CVE-2019-13283

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:gir1.2-poppler-0.18, p-cpe:/a:canonical:ubuntu_linux:libpoppler-cpp-dev, p-cpe:/a:canonical:ubuntu_linux:libpoppler-cpp0, p-cpe:/a:canonical:ubuntu_linux:libpoppler-cpp0v5, p-cpe:/a:canonical:ubuntu_linux:libpoppler-dev, p-cpe:/a:canonical:ubuntu_linux:libpoppler-glib-dev, p-cpe:/a:canonical:ubuntu_linux:libpoppler-glib8, p-cpe:/a:canonical:ubuntu_linux:libpoppler-private-dev, p-cpe:/a:canonical:ubuntu_linux:libpoppler-qt4-4, p-cpe:/a:canonical:ubuntu_linux:libpoppler-qt4-dev, p-cpe:/a:canonical:ubuntu_linux:libpoppler-qt5-1, p-cpe:/a:canonical:ubuntu_linux:libpoppler-qt5-dev, p-cpe:/a:canonical:ubuntu_linux:libpoppler58, p-cpe:/a:canonical:ubuntu_linux:libpoppler73, p-cpe:/a:canonical:ubuntu_linux:poppler-utils

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/11/25

Vulnerability Publication Date: 2019/04/03

Reference Information

CVE: CVE-2018-21009, CVE-2019-9959, CVE-2019-10871, CVE-2019-13283, CVE-2020-27778

BID: 107862, 109342

USN: 4646-1