phpMyAdmin 4.3.x < 4.7.8 XSS (PMASA-2018-1)

medium Nessus Plugin ID 143262


The remote web server hosts a PHP application that is affected by a cross-site scripting vulnerability.


According to its self-reported version, the phpMyAdmin application hosted on the remote web server is 4.7.x prior to 4.7.8. Versions since 4.3 are also affected, but they are no longer supported. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in db_central_columns.php. A remote, authenticated attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to phpMyAdmin version 4.7.8 or later.

See Also

Plugin Details

Severity: Medium

ID: 143262

File Name: phpmyadmin_pmasa_2018_1.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 11/25/2020

Updated: 6/4/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.8


Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2018-7260


Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/phpMyAdmin

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/20/2018

Vulnerability Publication Date: 2/20/2018

Reference Information

CVE: CVE-2018-7260

BID: 103099

CWE: 661, 79