Microsoft Edge (Chromium) < 87.0.664.41 Multiple Vulnerabilities

high Nessus Plugin ID 143156
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has an web browser installed that is affected by multiple vulnerabilities.

Description

The version of Microsoft Edge installed on the remote Windows host is prior to 87.0.664.41. It is, therefore, affected by multiple vulnerabilities as referenced in the ADV200002-11-19-2020 advisory.

- Adobe Flash Player version 32.0.0.192 and earlier versions have a Same Origin Policy Bypass vulnerability.
Successful exploitation could lead to Information Disclosure in the context of the current user.
(CVE-2019-8075)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Microsoft Edge version 87.0.664.41 or later.

See Also

http://www.nessus.org/u?083510ae

Plugin Details

Severity: High

ID: 143156

File Name: microsoft_edge_chromium_87_0_664_41.nasl

Version: 1.5

Type: local

Agent: windows

Family: Windows

Published: 11/20/2020

Updated: 2/11/2021

Dependencies: microsoft_edge_chromium_installed.nbin

Risk Information

CVSS Score Source: CVE-2020-16029

VPR

Risk Factor: High

Score: 8.1

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:edge

Required KB Items: installed_sw/Microsoft Edge (Chromium), SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/19/2020

Vulnerability Publication Date: 6/11/2019

Reference Information

CVE: CVE-2019-8075, CVE-2020-16012, CVE-2020-16014, CVE-2020-16015, CVE-2020-16018, CVE-2020-16022, CVE-2020-16023, CVE-2020-16024, CVE-2020-16025, CVE-2020-16026, CVE-2020-16027, CVE-2020-16028, CVE-2020-16029, CVE-2020-16030, CVE-2020-16031, CVE-2020-16032, CVE-2020-16033, CVE-2020-16034, CVE-2020-16036