Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 : Kerberos vulnerability (USN-4635-1)

Medium Nessus Plugin ID 142967

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.6

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS / 20.10 host has packages installed that are affected by a vulnerability as referenced in the USN-4635-1 advisory.

- MIT Kerberos 5 (aka krb5) before 1.17.2 and 1.18.x before 1.18.3 allows unbounded recursion via an ASN.1-encoded Kerberos message because the lib/krb5/asn.1/asn1_encode.c support for BER indefinite lengths lacks a recursion limit. (CVE-2020-28196)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4635-1

Plugin Details

Severity: Medium

ID: 142967

File Name: ubuntu_USN-4635-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2020/11/17

Updated: 2020/11/24

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS Score Source: CVE-2020-28196

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.10, p-cpe:/a:canonical:ubuntu_linux:krb5-admin-server, p-cpe:/a:canonical:ubuntu_linux:krb5-gss-samples, p-cpe:/a:canonical:ubuntu_linux:krb5-k5tls, p-cpe:/a:canonical:ubuntu_linux:krb5-kdc, p-cpe:/a:canonical:ubuntu_linux:krb5-kdc-ldap, p-cpe:/a:canonical:ubuntu_linux:krb5-kpropd, p-cpe:/a:canonical:ubuntu_linux:krb5-locales, p-cpe:/a:canonical:ubuntu_linux:krb5-multidev, p-cpe:/a:canonical:ubuntu_linux:krb5-otp, p-cpe:/a:canonical:ubuntu_linux:krb5-pkinit, p-cpe:/a:canonical:ubuntu_linux:krb5-user, p-cpe:/a:canonical:ubuntu_linux:libgssapi-krb5-2, p-cpe:/a:canonical:ubuntu_linux:libgssrpc4, p-cpe:/a:canonical:ubuntu_linux:libk5crypto3, p-cpe:/a:canonical:ubuntu_linux:libkadm5clnt-mit11, p-cpe:/a:canonical:ubuntu_linux:libkadm5clnt-mit9, p-cpe:/a:canonical:ubuntu_linux:libkadm5srv-mit11, p-cpe:/a:canonical:ubuntu_linux:libkadm5srv-mit8, p-cpe:/a:canonical:ubuntu_linux:libkadm5srv-mit9, p-cpe:/a:canonical:ubuntu_linux:libkdb5-7, p-cpe:/a:canonical:ubuntu_linux:libkdb5-8, p-cpe:/a:canonical:ubuntu_linux:libkdb5-9, p-cpe:/a:canonical:ubuntu_linux:libkrad-dev, p-cpe:/a:canonical:ubuntu_linux:libkrad0, p-cpe:/a:canonical:ubuntu_linux:libkrb5-3, p-cpe:/a:canonical:ubuntu_linux:libkrb5-dev, p-cpe:/a:canonical:ubuntu_linux:libkrb5support0

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/11/17

Vulnerability Publication Date: 2020/11/06

Reference Information

CVE: CVE-2020-28196

USN: 4635-1