Oracle Linux 8 : grafana (ELSA-2020-4682)

Medium Nessus Plugin ID 142792

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2020-4682 advisory.

- An information-disclosure flaw was found in Grafana through 6.7.3. The database directory /var/lib/grafana and database file /var/lib/grafana/grafana.db are world readable. This can result in exposure of sensitive information (e.g., cleartext or encrypted datasource passwords). (CVE-2020-12458)

- Grafana before 6.7.3 allows table-panel XSS via column.title or cellLinkTooltip. (CVE-2020-12245)

- Grafana <= 6.4.3 has an Arbitrary File Read vulnerability, which could be exploited by an authenticated attacker that has privileges to modify the data source configurations. (CVE-2019-19499)

- Grafana before 7.0.0 allows tag value XSS via the OpenTSDB datasource. (CVE-2020-13430)

- Grafana 5.3.1 has XSS via a column style on the Dashboard > Table Panel screen. NOTE: this issue exists because of an incomplete fix for CVE-2018-12099. (CVE-2018-18624)

- Grafana through 6.7.1 allows stored XSS due to insufficient input protection in the originalUrl field, which allows an attacker to inject JavaScript code that will be executed after clicking on Open Original Dashboard after visiting the snapshot. (CVE-2020-11110)

- Grafana version < 6.7.3 is vulnerable for annotation popup XSS. (CVE-2020-12052)

- In certain Red Hat packages for Grafana 6.x through 6.3.6, the configuration files /etc/grafana/grafana.ini and /etc/grafana/ldap.toml (which contain a secret_key and a bind_password) are world readable. (CVE-2020-12459)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://linux.oracle.com/errata/ELSA-2020-4682.html

Plugin Details

Severity: Medium

ID: 142792

File Name: oraclelinux_ELSA-2020-4682.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2020/11/12

Updated: 2020/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS Score Source: CVE-2020-13430

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:grafana, p-cpe:/a:oracle:linux:grafana-azure-monitor, p-cpe:/a:oracle:linux:grafana-cloudwatch, p-cpe:/a:oracle:linux:grafana-elasticsearch, p-cpe:/a:oracle:linux:grafana-graphite, p-cpe:/a:oracle:linux:grafana-influxdb, p-cpe:/a:oracle:linux:grafana-loki, p-cpe:/a:oracle:linux:grafana-mssql, p-cpe:/a:oracle:linux:grafana-mysql, p-cpe:/a:oracle:linux:grafana-opentsdb, p-cpe:/a:oracle:linux:grafana-postgres, p-cpe:/a:oracle:linux:grafana-prometheus, p-cpe:/a:oracle:linux:grafana-stackdriver

Required KB Items: Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/11/10

Vulnerability Publication Date: 2020/04/24

Reference Information

CVE: CVE-2018-18624, CVE-2019-19499, CVE-2020-11110, CVE-2020-12052, CVE-2020-12245, CVE-2020-12458, CVE-2020-12459, CVE-2020-13430