Amazon Linux 2 : pcp (ALAS-2020-1561)

High Nessus Plugin ID 142734

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of tested product installed on the remote host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2020-1561 advisory.

- A Improper Control of Generation of Code vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5; openSUSE Leap 15.1 allows the user pcp to run code as root by placing it into /var/log/pcp/configs.sh This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1.
SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1.
(CVE-2019-3695)

- A Improper Limitation of a Pathname to a Restricted Directory vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5; openSUSE Leap 15.1 allows local user pcp to overwrite arbitrary files with arbitrary content. This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1. (CVE-2019-3696)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update pcp' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2020-1561.html

https://access.redhat.com/security/cve/CVE-2019-3695

https://access.redhat.com/security/cve/CVE-2019-3696

Plugin Details

Severity: High

ID: 142734

File Name: al2_ALAS-2020-1561.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/11/11

Updated: 2020/11/11

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS Score Source: CVE-2019-3695

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:pcp, p-cpe:/a:amazon:linux:pcp-conf, p-cpe:/a:amazon:linux:pcp-debuginfo, p-cpe:/a:amazon:linux:pcp-devel, p-cpe:/a:amazon:linux:pcp-doc, p-cpe:/a:amazon:linux:pcp-export-pcp2elasticsearch, p-cpe:/a:amazon:linux:pcp-export-pcp2graphite, p-cpe:/a:amazon:linux:pcp-export-pcp2influxdb, p-cpe:/a:amazon:linux:pcp-export-pcp2json, p-cpe:/a:amazon:linux:pcp-export-pcp2spark, p-cpe:/a:amazon:linux:pcp-export-pcp2xml, p-cpe:/a:amazon:linux:pcp-export-pcp2zabbix, p-cpe:/a:amazon:linux:pcp-export-zabbix-agent, p-cpe:/a:amazon:linux:pcp-gui, p-cpe:/a:amazon:linux:pcp-import-collectl2pcp, p-cpe:/a:amazon:linux:pcp-import-ganglia2pcp, p-cpe:/a:amazon:linux:pcp-import-iostat2pcp, p-cpe:/a:amazon:linux:pcp-import-mrtg2pcp, p-cpe:/a:amazon:linux:pcp-import-sar2pcp, p-cpe:/a:amazon:linux:pcp-libs, p-cpe:/a:amazon:linux:pcp-libs-devel, p-cpe:/a:amazon:linux:pcp-manager, p-cpe:/a:amazon:linux:pcp-pmda-activemq, p-cpe:/a:amazon:linux:pcp-pmda-apache, p-cpe:/a:amazon:linux:pcp-pmda-bash, p-cpe:/a:amazon:linux:pcp-pmda-bind2, p-cpe:/a:amazon:linux:pcp-pmda-bonding, p-cpe:/a:amazon:linux:pcp-pmda-cifs, p-cpe:/a:amazon:linux:pcp-pmda-cisco, p-cpe:/a:amazon:linux:pcp-pmda-dbping, p-cpe:/a:amazon:linux:pcp-pmda-dm, p-cpe:/a:amazon:linux:pcp-pmda-docker, p-cpe:/a:amazon:linux:pcp-pmda-ds389, p-cpe:/a:amazon:linux:pcp-pmda-ds389log, p-cpe:/a:amazon:linux:pcp-pmda-elasticsearch, p-cpe:/a:amazon:linux:pcp-pmda-gfs2, p-cpe:/a:amazon:linux:pcp-pmda-gluster, p-cpe:/a:amazon:linux:pcp-pmda-gpfs, p-cpe:/a:amazon:linux:pcp-pmda-gpsd, p-cpe:/a:amazon:linux:pcp-pmda-haproxy, p-cpe:/a:amazon:linux:pcp-pmda-infiniband, p-cpe:/a:amazon:linux:pcp-pmda-json, p-cpe:/a:amazon:linux:pcp-pmda-libvirt, p-cpe:/a:amazon:linux:pcp-pmda-lio, p-cpe:/a:amazon:linux:pcp-pmda-lmsensors, p-cpe:/a:amazon:linux:pcp-pmda-logger, p-cpe:/a:amazon:linux:pcp-pmda-lustre, p-cpe:/a:amazon:linux:pcp-pmda-lustrecomm, p-cpe:/a:amazon:linux:pcp-pmda-mailq, p-cpe:/a:amazon:linux:pcp-pmda-memcache, p-cpe:/a:amazon:linux:pcp-pmda-mic, p-cpe:/a:amazon:linux:pcp-pmda-mounts, p-cpe:/a:amazon:linux:pcp-pmda-mysql, p-cpe:/a:amazon:linux:pcp-pmda-named, p-cpe:/a:amazon:linux:pcp-pmda-netfilter, p-cpe:/a:amazon:linux:pcp-pmda-news, p-cpe:/a:amazon:linux:pcp-pmda-nfsclient, p-cpe:/a:amazon:linux:pcp-pmda-nginx, p-cpe:/a:amazon:linux:pcp-pmda-nvidia-gpu, p-cpe:/a:amazon:linux:pcp-pmda-oracle, p-cpe:/a:amazon:linux:pcp-pmda-pdns, p-cpe:/a:amazon:linux:pcp-pmda-perfevent, p-cpe:/a:amazon:linux:pcp-pmda-postfix, p-cpe:/a:amazon:linux:pcp-pmda-postgresql, p-cpe:/a:amazon:linux:pcp-pmda-prometheus, p-cpe:/a:amazon:linux:pcp-pmda-redis, p-cpe:/a:amazon:linux:pcp-pmda-roomtemp, p-cpe:/a:amazon:linux:pcp-pmda-rpm, p-cpe:/a:amazon:linux:pcp-pmda-rsyslog, p-cpe:/a:amazon:linux:pcp-pmda-samba, p-cpe:/a:amazon:linux:pcp-pmda-sendmail, p-cpe:/a:amazon:linux:pcp-pmda-shping, p-cpe:/a:amazon:linux:pcp-pmda-slurm, p-cpe:/a:amazon:linux:pcp-pmda-smart, p-cpe:/a:amazon:linux:pcp-pmda-snmp, p-cpe:/a:amazon:linux:pcp-pmda-summary, p-cpe:/a:amazon:linux:pcp-pmda-systemd, p-cpe:/a:amazon:linux:pcp-pmda-trace, p-cpe:/a:amazon:linux:pcp-pmda-unbound, p-cpe:/a:amazon:linux:pcp-pmda-vmware, p-cpe:/a:amazon:linux:pcp-pmda-weblog, p-cpe:/a:amazon:linux:pcp-pmda-zimbra, p-cpe:/a:amazon:linux:pcp-pmda-zswap, p-cpe:/a:amazon:linux:pcp-selinux, p-cpe:/a:amazon:linux:pcp-system-tools, p-cpe:/a:amazon:linux:pcp-testsuite, p-cpe:/a:amazon:linux:pcp-webapi, p-cpe:/a:amazon:linux:pcp-webapp-blinkenlights, p-cpe:/a:amazon:linux:pcp-webapp-grafana, p-cpe:/a:amazon:linux:pcp-webapp-graphite, p-cpe:/a:amazon:linux:pcp-webapp-vector, p-cpe:/a:amazon:linux:pcp-webjs, p-cpe:/a:amazon:linux:pcp-zeroconf, p-cpe:/a:amazon:linux:perl-PCP-LogImport, p-cpe:/a:amazon:linux:perl-PCP-LogSummary, p-cpe:/a:amazon:linux:perl-PCP-MMV, p-cpe:/a:amazon:linux:perl-PCP-PMDA, p-cpe:/a:amazon:linux:python-pcp, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/11/09

Vulnerability Publication Date: 2020/03/03

Reference Information

CVE: CVE-2019-3695, CVE-2019-3696

ALAS: 2020-1561