RHEL 7 : tomcat (RHSA-2020:5020)

medium Nessus Plugin ID 142708

Synopsis

The remote Red Hat host is missing a security update for tomcat.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2020:5020 advisory.

- tomcat: Mishandling of Transfer-Encoding header allows for HTTP request smuggling (CVE-2020-1935)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the RHEL tomcat package based on the guidance in RHSA-2020:5020.

See Also

http://www.nessus.org/u?ead64edc

https://access.redhat.com/security/updates/classification/#low

https://access.redhat.com/errata/RHSA-2020:5020

https://bugzilla.redhat.com/show_bug.cgi?id=1806835

Plugin Details

Severity: Medium

ID: 142708

File Name: redhat-RHSA-2020-5020.nasl

Version: 1.10

Type: local

Agent: unix

Published: 11/11/2020

Updated: 4/28/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.3

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2020-1935

CVSS v3

Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:tomcat, p-cpe:/a:redhat:enterprise_linux:tomcat-admin-webapps, p-cpe:/a:redhat:enterprise_linux:tomcat-docs-webapp, p-cpe:/a:redhat:enterprise_linux:tomcat-el-2.2-api, p-cpe:/a:redhat:enterprise_linux:tomcat-javadoc, p-cpe:/a:redhat:enterprise_linux:tomcat-jsp-2.2-api, p-cpe:/a:redhat:enterprise_linux:tomcat-jsvc, p-cpe:/a:redhat:enterprise_linux:tomcat-lib, p-cpe:/a:redhat:enterprise_linux:tomcat-servlet-3.0-api, p-cpe:/a:redhat:enterprise_linux:tomcat-webapps

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 11/10/2020

Vulnerability Publication Date: 2/11/2020

Reference Information

CVE: CVE-2020-1935

CWE: 444

IAVB: 2020-B-0010-S

RHSA: 2020:5020