RHEL 8 : python38:3.8 (RHSA-2020:4641)

critical Nessus Plugin ID 142431
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2020:4641 advisory.

- PyYAML: command execution through python/object/apply constructor in FullLoader (CVE-2019-20477)

- python: infinite loop in the tarfile module via crafted TAR archive (CVE-2019-20907)

- python: DoS via inefficiency in IPv{4,6}Interface classes (CVE-2020-14422)

- PyYAML: arbitrary command execution through python/object/new when FullLoader is used (CVE-2020-1747)

- python: wrong backtracking in urllib.request.AbstractBasicAuthHandler allows for a ReDoS (CVE-2020-8492)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/400.html

https://cwe.mitre.org/data/definitions/502.html

https://cwe.mitre.org/data/definitions/835.html

https://access.redhat.com/security/cve/CVE-2019-20477

https://access.redhat.com/security/cve/CVE-2019-20907

https://access.redhat.com/security/cve/CVE-2020-1747

https://access.redhat.com/security/cve/CVE-2020-8492

https://access.redhat.com/security/cve/CVE-2020-14422

https://access.redhat.com/errata/RHSA-2020:4641

https://bugzilla.redhat.com/1806005

https://bugzilla.redhat.com/1807367

https://bugzilla.redhat.com/1809065

https://bugzilla.redhat.com/1854926

https://bugzilla.redhat.com/1856481

Plugin Details

Severity: Critical

ID: 142431

File Name: redhat-RHSA-2020-4641.nasl

Version: 1.5

Type: local

Agent: unix

Published: 11/4/2020

Updated: 3/24/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Critical

VPR Score: 5.9

CVSS Score Source: CVE-2020-1747

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:Cython-debugsource, p-cpe:/a:redhat:enterprise_linux:PyYAML-debugsource, p-cpe:/a:redhat:enterprise_linux:numpy-debugsource, p-cpe:/a:redhat:enterprise_linux:python-cffi-debugsource, p-cpe:/a:redhat:enterprise_linux:python-cryptography-debugsource, p-cpe:/a:redhat:enterprise_linux:python-lxml-debugsource, p-cpe:/a:redhat:enterprise_linux:python-markupsafe-debugsource, p-cpe:/a:redhat:enterprise_linux:python-psutil-debugsource, p-cpe:/a:redhat:enterprise_linux:python-psycopg2-debugsource, p-cpe:/a:redhat:enterprise_linux:python38, p-cpe:/a:redhat:enterprise_linux:python38-Cython, p-cpe:/a:redhat:enterprise_linux:python38-PyMySQL, p-cpe:/a:redhat:enterprise_linux:python38-asn1crypto, p-cpe:/a:redhat:enterprise_linux:python38-babel, p-cpe:/a:redhat:enterprise_linux:python38-cffi, p-cpe:/a:redhat:enterprise_linux:python38-chardet, p-cpe:/a:redhat:enterprise_linux:python38-cryptography, p-cpe:/a:redhat:enterprise_linux:python38-debug, p-cpe:/a:redhat:enterprise_linux:python38-debugsource, p-cpe:/a:redhat:enterprise_linux:python38-devel, p-cpe:/a:redhat:enterprise_linux:python38-idle, p-cpe:/a:redhat:enterprise_linux:python38-idna, p-cpe:/a:redhat:enterprise_linux:python38-jinja2, p-cpe:/a:redhat:enterprise_linux:python38-libs, p-cpe:/a:redhat:enterprise_linux:python38-lxml, p-cpe:/a:redhat:enterprise_linux:python38-markupsafe, p-cpe:/a:redhat:enterprise_linux:python38-mod_wsgi, p-cpe:/a:redhat:enterprise_linux:python38-numpy, p-cpe:/a:redhat:enterprise_linux:python38-numpy-doc, p-cpe:/a:redhat:enterprise_linux:python38-numpy-f2py, p-cpe:/a:redhat:enterprise_linux:python38-pip, p-cpe:/a:redhat:enterprise_linux:python38-pip-wheel, p-cpe:/a:redhat:enterprise_linux:python38-ply, p-cpe:/a:redhat:enterprise_linux:python38-psutil, p-cpe:/a:redhat:enterprise_linux:python38-psycopg2, p-cpe:/a:redhat:enterprise_linux:python38-psycopg2-doc, p-cpe:/a:redhat:enterprise_linux:python38-psycopg2-tests, p-cpe:/a:redhat:enterprise_linux:python38-pycparser, p-cpe:/a:redhat:enterprise_linux:python38-pysocks, p-cpe:/a:redhat:enterprise_linux:python38-pytz, p-cpe:/a:redhat:enterprise_linux:python38-pyyaml, p-cpe:/a:redhat:enterprise_linux:python38-requests, p-cpe:/a:redhat:enterprise_linux:python38-rpm-macros, p-cpe:/a:redhat:enterprise_linux:python38-scipy, p-cpe:/a:redhat:enterprise_linux:python38-setuptools, p-cpe:/a:redhat:enterprise_linux:python38-setuptools-wheel, p-cpe:/a:redhat:enterprise_linux:python38-six, p-cpe:/a:redhat:enterprise_linux:python38-test, p-cpe:/a:redhat:enterprise_linux:python38-tkinter, p-cpe:/a:redhat:enterprise_linux:python38-urllib3, p-cpe:/a:redhat:enterprise_linux:python38-wheel, p-cpe:/a:redhat:enterprise_linux:python38-wheel-wheel, p-cpe:/a:redhat:enterprise_linux:scipy-debugsource

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 11/4/2020

Vulnerability Publication Date: 1/30/2020

Reference Information

CVE: CVE-2019-20477, CVE-2019-20907, CVE-2020-1747, CVE-2020-8492, CVE-2020-14422

RHSA: 2020:4641

CWE: 20, 400, 502, 835