4D WebSTAR Symlink Privilege Escalation

Low Nessus Plugin ID 14241


The remote FTP server is affected by a local symbolic link vulnerability.


The remote server is running 4D WebStar FTP Server. The version of 4D WebStar FTP Server on the remote host is reportedly affected by a local symbolic link vulnerability caused by the application opening files without properly verifying their existence or their absolute location.

Successful exploitation of this issue will allow an attacker to write to arbitrary files subject to the permissions of the affected application.


Upgrade to 4D WebStar 5.3.3 or later.

See Also


Plugin Details

Severity: Low

ID: 14241

File Name: 4d_webstar_symb_link.nasl

Version: $Revision: 1.19 $

Type: remote

Family: FTP

Published: 2004/08/09

Modified: 2016/09/22

Dependencies: 10107, 10092

Risk Information

Risk Factor: Low


Base Score: 3.6

Temporal Score: 3

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2004/07/13

Reference Information

CVE: CVE-2004-0698

BID: 10714

OSVDB: 7797

Secunia: 12063