SquirrelMail < 1.4.3 Multiple Vulnerabilities

high Nessus Plugin ID 14228

Synopsis

The remote service is vulnerable to injection attacks allowing command execution.

Description

The remote host is running SquirrelMail, a web-based mail server.

There are several flaws in all versions less than 1.4.3 and development versions 1.5.0 and 1.5.1 that allow for local root access and remote cross-site scripting (XSS) attacks.

***** Nessus has determined the vulnerability exists on the target
***** simply by looking at the version number of Squirrelmail
***** installed there.

Solution

Upgrade to SquirrelMail 1.4.3 or greater.

See Also

https://marc.info/?l=bugtraq&m=108334862800260

http://www.securityfocus.com/advisories/6761

Plugin Details

Severity: High

ID: 14228

File Name: squirrelmail_143.nasl

Version: 1.37

Type: remote

Family: CGI abuses

Published: 5/5/2004

Updated: 5/12/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squirrelmail:squirrelmail

Required KB Items: www/squirrelmail

Exploit Ease: No exploit is required

Vulnerability Publication Date: 4/27/2004

Reference Information

CVE: CVE-2004-0519, CVE-2004-0520, CVE-2004-0521

BID: 10246, 10397, 10439

GLSA: GLSA-200405-16:02, GLSA-200406-08

RHSA: 2004:240-06

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990