Debian DLA-2422-1 : qtsvg-opensource-src security update

medium Nessus Plugin ID 142202

Synopsis

The remote Debian host is missing a security update.

Description

Malformed SVG images were able to cause a segmentation fault in qtsvg-opensource-src, the QtSvg module for displaying the contents of SVG files in Qt.

For Debian 9 stretch, this problem has been fixed in version 5.7.1~20161021-2.1.

We recommend that you upgrade your qtsvg-opensource-src packages.

For the detailed security status of qtsvg-opensource-src please refer to its security tracker page at:
https://security-tracker.debian.org/tracker/qtsvg-opensource-src

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2020/10/msg00035.html

https://packages.debian.org/source/stretch/qtsvg-opensource-src

http://www.nessus.org/u?de7057e6

Plugin Details

Severity: Medium

ID: 142202

File Name: debian_DLA-2422.nasl

Version: 1.2

Type: local

Agent: unix

Published: 11/2/2020

Updated: 11/6/2020

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libqt5svg5, p-cpe:/a:debian:debian_linux:libqt5svg5-dev, p-cpe:/a:debian:debian_linux:qtsvg5-dbg, p-cpe:/a:debian:debian_linux:qtsvg5-doc, p-cpe:/a:debian:debian_linux:qtsvg5-doc-html, p-cpe:/a:debian:debian_linux:qtsvg5-examples, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/31/2020

Vulnerability Publication Date: 12/26/2018

Reference Information

CVE: CVE-2018-19869