Tenable Nessus < 8.12.1 Privilege Escalation Vulnerability (TNS-2020-08)

high Nessus Plugin ID 142144
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Tenable Nessus running on the remote host is affected by a privilege escalation vulnerability.

Description

A vulnerability in Nessus versions 8.9.0 through 8.12.0 could allow an authenticated local attacker to copy user-supplied files to a specially constructed path in a specifically named user directory. An attacker could exploit this vulnerability by creating a malicious file and copying the file to a system directory. The attacker needs valid credentials to exploit this vulnerability.


Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tenable Nessus version 8.12.1 or later.

See Also

https://www.tenable.com/security/TNS-2020-08

Plugin Details

Severity: High

ID: 142144

File Name: nessus_tns_2020_08.nasl

Version: 1.7

Type: remote

Family: Misc.

Published: 10/30/2020

Updated: 3/12/2021

Dependencies: nessus_detect.nasl

Risk Information

CVSS Score Source: CVE-2020-5793

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Ease: No known exploits are available

Patch Publication Date: 10/29/2020

Vulnerability Publication Date: 10/29/2020

Reference Information

CVE: CVE-2020-5793