Amazon Linux AMI : postgresql96 (ALAS-2020-1443)

Medium Nessus Plugin ID 141979

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

The version of tested product installed on the remote host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS-2020-1443 advisory.

- A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to, excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics, such as histograms and lists of most common values, contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which, in an ordinary query, row- level security prunes the set of rows visible to the attacker. (CVE-2019-10130)

- A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY DEFINER function. An attacker, with EXECUTE permission on the function, can execute arbitrary SQL as the owner of the function. (CVE-2019-10208)

- It was found that some PostgreSQL extensions did not use search_path safely in their installation script.
An attacker with sufficient privileges could use this flaw to trick an administrator into executing a specially crafted script, during the installation or update of such extension. This affects PostgreSQL versions before 12.4, before 11.9, before 10.14, before 9.6.19, and before 9.5.23. (CVE-2020-14350)

- A flaw was found in PostgreSQL's ALTER ... DEPENDS ON EXTENSION, where sub-commands did not perform authorization checks. An authenticated attacker could use this flaw in certain configurations to perform drop objects such as function, triggers, et al., leading to database corruption. This issue affects PostgreSQL versions before 12.2, before 11.7, before 10.12 and before 9.6.17. (CVE-2020-1720)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update postgresql96' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2020-1443.html

https://access.redhat.com/security/cve/CVE-2019-10130

https://access.redhat.com/security/cve/CVE-2019-10208

https://access.redhat.com/security/cve/CVE-2020-14350

https://access.redhat.com/security/cve/CVE-2020-1720

Plugin Details

Severity: Medium

ID: 141979

File Name: ala_ALAS-2020-1443.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/10/28

Updated: 2020/10/28

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.9

CVSS Score Source: CVE-2019-10208

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql96, p-cpe:/a:amazon:linux:postgresql96-contrib, p-cpe:/a:amazon:linux:postgresql96-debuginfo, p-cpe:/a:amazon:linux:postgresql96-devel, p-cpe:/a:amazon:linux:postgresql96-docs, p-cpe:/a:amazon:linux:postgresql96-libs, p-cpe:/a:amazon:linux:postgresql96-plperl, p-cpe:/a:amazon:linux:postgresql96-plpython26, p-cpe:/a:amazon:linux:postgresql96-plpython27, p-cpe:/a:amazon:linux:postgresql96-server, p-cpe:/a:amazon:linux:postgresql96-static, p-cpe:/a:amazon:linux:postgresql96-test, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/10/26

Vulnerability Publication Date: 2019/05/09

Reference Information

CVE: CVE-2019-10130, CVE-2019-10208, CVE-2020-1720, CVE-2020-14350

BID: 108452

ALAS: 2020-1443