GLSA-202010-07 : FreeType: Arbitrary code execution

medium Nessus Plugin ID 141837

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202010-07 (FreeType: Arbitrary code execution)

A flaw in FreeType’s handling of embedded PNG bitmaps was discovered where the image height and width was not checked to be within bounds.
Impact :

A remote attacker could entice a user to open a specially crafted font file using FreeType possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All FreeType users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/freetype-2.10.3-r1'

See Also

https://savannah.nongnu.org/bugs/?59308

https://security.gentoo.org/glsa/202010-07

Plugin Details

Severity: Medium

ID: 141837

File Name: gentoo_GLSA-202010-07.nasl

Version: 1.6

Type: local

Published: 10/23/2020

Updated: 11/30/2021

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:freetype, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/23/2020

Vulnerability Publication Date: 11/3/2020

CISA Known Exploited Dates: 11/17/2021

Reference Information

CVE: CVE-2020-15999

GLSA: 202010-07