Mandrake Linux Security Advisory : wv (MDKSA-2004:077)

Critical Nessus Plugin ID 14175


The remote Mandrake Linux host is missing one or more security updates.


iDefense discovered a buffer overflow vulnerability in the wv package which could allow an attacker to execute arbitrary code with the privileges of the user running the vulnerable application.

The updated packages are patched to protect against this problem.


Update the affected packages.

See Also

Plugin Details

Severity: Critical

ID: 14175

File Name: mandrake_MDKSA-2004-077.nasl

Version: $Revision: 1.20 $

Type: local

Published: 2004/07/31

Modified: 2013/06/02

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64wv-1.0_0, p-cpe:/a:mandriva:linux:lib64wv-1.0_0-devel, p-cpe:/a:mandriva:linux:libwv-1.0_0, p-cpe:/a:mandriva:linux:libwv-1.0_0-devel, p-cpe:/a:mandriva:linux:wv, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/07/29

Reference Information

CVE: CVE-2004-0645

MDKSA: 2004:077