Mandrake Linux Security Advisory : sox (MDKSA-2004:076)

Critical Nessus Plugin ID 14174


The remote Mandrake Linux host is missing one or more security updates.


Ulf Harnhammar discovered two buffer overflows in SoX. They occur when the sox or play commands handle malicious .WAV files.

Versions 12.17.4, 12.17.3 and 12.17.2 are vulnerable to these overflows. 12.17.1, 12.17 and 12.16 are some versions that are not.


Update the affected sox and / or sox-devel packages.

Plugin Details

Severity: Critical

ID: 14174

File Name: mandrake_MDKSA-2004-076.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:sox, p-cpe:/a:mandriva:linux:sox-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:9.1, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/07/28

Reference Information

CVE: CVE-2004-0557

MDKSA: 2004:076