Scientific Linux Security Update : httpd on SL7.x x86_64 (20201001)

high Nessus Plugin ID 141711

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Security Fix(es) :

- httpd: Improper handling of headers in mod_session can allow a remote user to modify session data for CGI applications (CVE-2018-1283)

- httpd: Out of bounds read in mod_cache_socache can allow a remote attacker to cause DoS (CVE-2018-1303)

- httpd: mod_rewrite configurations vulnerable to open redirect (CVE-2020-1927)

- httpd: <FilesMatch> bypass with a trailing newline in the file name (CVE-2017-15715)

- httpd: mod_rewrite potential open redirect (CVE-2019-10098)

- httpd: mod_proxy_ftp use of uninitialized value (CVE-2020-1934)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?df1a2c51

Plugin Details

Severity: High

ID: 141711

File Name: sl_20201001_httpd_on_SL7_x.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/21/2020

Updated: 10/23/2020

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:fermilab:scientific_linux:httpd, p-cpe:/a:fermilab:scientific_linux:httpd-debuginfo, p-cpe:/a:fermilab:scientific_linux:httpd-devel, p-cpe:/a:fermilab:scientific_linux:httpd-manual, p-cpe:/a:fermilab:scientific_linux:httpd-tools, p-cpe:/a:fermilab:scientific_linux:mod_ldap, p-cpe:/a:fermilab:scientific_linux:mod_proxy_html, p-cpe:/a:fermilab:scientific_linux:mod_session, p-cpe:/a:fermilab:scientific_linux:mod_ssl, x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/1/2020

Vulnerability Publication Date: 3/26/2018

Reference Information

CVE: CVE-2017-15715, CVE-2018-1283, CVE-2018-1303, CVE-2019-10098, CVE-2020-1927, CVE-2020-1934