PHP 7.2 < 7.2.34 / 7.3.x < 7.3.23 / 7.4.x < 7.4.11 Mulitiple Vulnerabilities

medium Nessus Plugin ID 141355


The version of PHP running on the remote web server is affected by multiple vulnerabilities


According to its self-reported version number, the version of PHP running on the remote web server is 7.2.x prior to 7.2.34, 7.3.x prior to 7.3.23 or 7.4.x prior to 7.4.11. It is, therefore, affected by multiple vulnerabilties:

- A weak cryptography vulnerability exists in PHP's openssl_encrypt function due to a failure to utilize all provided IV bytes. An unauthenticated, remote attacker could exploit this to reduce the level of security provided by the encryption scheme or affect the integrity of the encrypted data (CVE-2020-7069).

- A cookie forgery vulnerability exists in PHP's HTTP processing functionality. An unauthenticated, remote could expoit this to forge HTTP cookies which were supposed to be secure. (CVE-2020-7070)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version


Upgrade to PHP version 7.2.34, 7.3.23, 7.4.11 or later.

See Also

Plugin Details

Severity: Medium

ID: 141355

File Name: php_7_4_11.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 10/9/2020

Updated: 2/15/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 2.5


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2020-7069


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/1/2020

Vulnerability Publication Date: 10/1/2020

Reference Information

CVE: CVE-2020-7069, CVE-2020-7070

IAVA: 2020-A-0445-S