Mandrake Linux Security Advisory : kdelibs (MDKSA-2004:022)

High Nessus Plugin ID 14121


The remote Mandrake Linux host is missing one or more security updates.


Corsaire discovered that a number of HTTP user agents contained a flaw in how they handle cookies. This flaw could allow an attacker to avoid the path restrictions specified by a cookie's originator. According to their advisory :

'The cookie specifications detail a path argument that can be used to restrict the areas of a host that will be exposed to a cookie. By using standard traversal techniques this functionality can be subverted, potentially exposing the cookie to scrutiny and use in further attacks.'

This issue was fixed in KDE 3.1.3; the updated packages are patched to protect against this vulnerability.


Update the affected packages.

Plugin Details

Severity: High

ID: 14121

File Name: mandrake_MDKSA-2004-022.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:kdelibs, p-cpe:/a:mandriva:linux:kdelibs-common, p-cpe:/a:mandriva:linux:kdelibs-devel, p-cpe:/a:mandriva:linux:kdelibs-static-devel, cpe:/o:mandrakesoft:mandrake_linux:9.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/03/10

Reference Information

CVE: CVE-2003-0592

MDKSA: 2004:022