Mandrake Linux Security Advisory : libxml2 (MDKSA-2004:018)

High Nessus Plugin ID 14118


The remote Mandrake Linux host is missing one or more security updates.


A flaw in libxml2 versions prior to 2.6.6 was found by Yuuichi Teranishi. When fetching a remote source via FTP or HTTP, libxml2 uses special parsing routines that can overflow a buffer if passed a very long URL. In the event that the attacker can find a program that uses libxml2 which parses remote resources and allows them to influence the URL, this flaw could be used to execute arbitrary code.

The updated packages provide a backported fix to correct the problem.


Update the affected packages.

Plugin Details

Severity: High

ID: 14118

File Name: mandrake_MDKSA-2004-018.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64xml2, p-cpe:/a:mandriva:linux:lib64xml2-devel, p-cpe:/a:mandriva:linux:lib64xml2-python, p-cpe:/a:mandriva:linux:libxml2, p-cpe:/a:mandriva:linux:libxml2-devel, p-cpe:/a:mandriva:linux:libxml2-python, p-cpe:/a:mandriva:linux:libxml2-utils, cpe:/o:mandrakesoft:mandrake_linux:9.1, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/03/03

Reference Information

CVE: CVE-2004-0110

MDKSA: 2004:018