Mandrake Linux Security Advisory : netpbm (MDKSA-2004:011-1)

Low Nessus Plugin ID 14111


The remote Mandrake Linux host is missing one or more security updates.


A number of temporary file bugs have been found in versions of NetPBM.
These could allow a local user the ability to overwrite or create files as a different user who happens to run one of the the vulnerable utilities.

Update :

The patch applied made some calls to the mktemp utility with an incorrect parameter which prevented mktemp from creating temporary files in some scripts.


Update the affected packages.

Plugin Details

Severity: Low

ID: 14111

File Name: mandrake_MDKSA-2004-011.nasl

Version: $Revision: 1.19 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.7

Vector: CVSS2#AV:L/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64netpbm9, p-cpe:/a:mandriva:linux:lib64netpbm9-devel, p-cpe:/a:mandriva:linux:lib64netpbm9-static-devel, p-cpe:/a:mandriva:linux:libnetpbm9, p-cpe:/a:mandriva:linux:libnetpbm9-devel, p-cpe:/a:mandriva:linux:libnetpbm9-static-devel, p-cpe:/a:mandriva:linux:netpbm, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/09/27

Reference Information

CVE: CVE-2003-0924

MDKSA: 2004:011-1