Mandrake Linux Security Advisory : glibc (MDKSA-2004:009)

Medium Nessus Plugin ID 14109


The remote Mandrake Linux host is missing one or more security updates.


A read buffer overflow vulnerability exists in the resolver code in versions of glibc up to and including 2.2.5. The vulnerability is triggered by DNS packets larger than 1024 bytes, which can cause an application to crash.

The updated packages have a patch applied to correct the problem.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 14109

File Name: mandrake_MDKSA-2004-009.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:glibc, p-cpe:/a:mandriva:linux:glibc-devel, p-cpe:/a:mandriva:linux:glibc-i18ndata, p-cpe:/a:mandriva:linux:glibc-profile, p-cpe:/a:mandriva:linux:glibc-static-devel, p-cpe:/a:mandriva:linux:glibc-utils, p-cpe:/a:mandriva:linux:ldconfig, p-cpe:/a:mandriva:linux:nscd, cpe:/o:mandrakesoft:mandrake_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/02/04

Reference Information

CVE: CVE-2002-1146

CERT: 738331

MDKSA: 2004:009