Mandrake Linux Security Advisory : mc (MDKSA-2004:007)

High Nessus Plugin ID 14107


The remote Mandrake Linux host is missing a security update.


A buffer overflow was discovered in mc's virtual filesystem code. This vulnerability could allow remote attackers to execute arbitrary code during symlink conversion.

The updated packages have been patched to correct the problem.


Update the affected mc package.

Plugin Details

Severity: High

ID: 14107

File Name: mandrake_MDKSA-2004-007.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mc, cpe:/o:mandrakesoft:mandrake_linux:9.1, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2004/01/26

Reference Information

CVE: CVE-2003-1023

MDKSA: 2004:007