Mandrake Linux Security Advisory : XFree86 (MDKSA-2003:118)

Critical Nessus Plugin ID 14100


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability was discovered in the XDM display manager that ships with XFree86. XDM does not check for successful completion of the pam_setcred() call and in the case of error conditions in the installed PAM modules, XDM may grant local root access to any user with valid login credentials. It has been reported that a certain configuration of the MIT pam_krb5 module can result in a failing pam_setcred() call which leaves the session alive and would provide root access to any regular user. It is also possible that this vulnerability can likewise be exploited with other PAM modules in a similar manner.

A backported patch from XFree86 4.3 that corrects this vulnerability has been applied to these updated packages.


Update the affected packages.

Plugin Details

Severity: Critical

ID: 14100

File Name: mandrake_MDKSA-2003-118.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2004/07/31

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:X11R6-contrib, p-cpe:/a:mandriva:linux:XFree86, p-cpe:/a:mandriva:linux:XFree86-100dpi-fonts, p-cpe:/a:mandriva:linux:XFree86-75dpi-fonts, p-cpe:/a:mandriva:linux:XFree86-Xnest, p-cpe:/a:mandriva:linux:XFree86-Xvfb, p-cpe:/a:mandriva:linux:XFree86-cyrillic-fonts, p-cpe:/a:mandriva:linux:XFree86-devel, p-cpe:/a:mandriva:linux:XFree86-doc, p-cpe:/a:mandriva:linux:XFree86-glide-module, p-cpe:/a:mandriva:linux:XFree86-libs, p-cpe:/a:mandriva:linux:XFree86-server, p-cpe:/a:mandriva:linux:XFree86-static-libs, p-cpe:/a:mandriva:linux:XFree86-xfs, p-cpe:/a:mandriva:linux:lib64xfree86, p-cpe:/a:mandriva:linux:lib64xfree86-devel, p-cpe:/a:mandriva:linux:lib64xfree86-static-devel, p-cpe:/a:mandriva:linux:libxfree86, p-cpe:/a:mandriva:linux:libxfree86-devel, p-cpe:/a:mandriva:linux:libxfree86-static-devel, cpe:/o:mandrakesoft:mandrake_linux:9.0, cpe:/o:mandrakesoft:mandrake_linux:9.1, cpe:/o:mandrakesoft:mandrake_linux:9.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2003/12/19

Reference Information

CVE: CVE-2003-0690

MDKSA: 2003:118