CodeMeter < 7.10 Information Exfiltration Vulnerability

high Nessus Plugin ID 140695
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A web application on the remote host is affected by a privilege escalation vulnerability.


According to its self-reported version, the CodeMeter WebAdmin server installed on the remote host is prior to 7.10. It is affected by a vulnerability where attacker could send a specially crafted packet that could have the server send back packets containing data from the heap.


Upgrade to CodeMeter 7.10 or later.

See Also

Plugin Details

Severity: High

ID: 140695

File Name: codemeter_webadmin_7_10.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 9/21/2020

Updated: 7/26/2021

Dependencies: codemeter_webadmin_detect.nasl

Risk Information

CVSS Score Source: CVE-2020-16233


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wibu:codemeter_runtime

Required KB Items: installed_sw/CodeMeter

Exploit Ease: No known exploits are available

Patch Publication Date: 9/4/2020

Vulnerability Publication Date: 9/4/2020

Reference Information

CVE: CVE-2020-16233