CodeMeter < 6.81 Denial of Service Vulnerability

high Nessus Plugin ID 140693
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A web application on the remote host is affected by a privilege escalation vulnerability.

Description

According to its self-reported version, the CodeMeter WebAdmin server installed on the remote host is prior to 6.81. It is affected by a Denial of Service Vulnerability while processing a specificaly crafted license file due to unverified lenght of fields.

Solution

Upgrade to CodeMeter 6.81 or later.

See Also

https://www.wibu.com/support/user/downloads-user-software.html

http://www.nessus.org/u?5663f6d4

http://www.nessus.org/u?c85150b5

Plugin Details

Severity: High

ID: 140693

File Name: codemeter_webadmin_6_81.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 9/21/2020

Updated: 9/25/2020

Dependencies: codemeter_webadmin_detect.nasl

Risk Information

CVSS Score Source: CVE-2020-14513

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wibu:codemeter_runtime

Required KB Items: installed_sw/CodeMeter

Exploit Ease: No known exploits are available

Patch Publication Date: 9/4/2020

Vulnerability Publication Date: 9/4/2020

Reference Information

CVE: CVE-2020-14513