CodeMeter < 6.81 Denial of Service Vulnerability

high Nessus Plugin ID 140693


A web application on the remote host is affected by a privilege escalation vulnerability.


According to its self-reported version, the CodeMeter WebAdmin server installed on the remote host is prior to 6.81. It is affected by a Denial of Service Vulnerability while processing a specificaly crafted license file due to unverified lenght of fields.


Upgrade to CodeMeter 6.81 or later.

See Also

Plugin Details

Severity: High

ID: 140693

File Name: codemeter_webadmin_6_81.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 9/21/2020

Updated: 9/25/2020

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-14513


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wibu:codemeter_runtime

Required KB Items: installed_sw/CodeMeter

Exploit Ease: No known exploits are available

Patch Publication Date: 9/4/2020

Vulnerability Publication Date: 9/4/2020

Reference Information

CVE: CVE-2020-14513