Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS : libproxy vulnerability (USN-4514-1)

Medium Nessus Plugin ID 140643

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4


The remote Ubuntu host is missing a security update.


The remote Ubuntu 16.04 LTS / 18.04 LTS / 20.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-4514-1 advisory.

- url::recvline in url.cpp in libproxy 0.4.x through 0.4.15 allows a remote HTTP server to trigger uncontrolled recursion via a response composed of an infinite stream that lacks a newline character. This leads to stack exhaustion. (CVE-2020-25219)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Update the affected packages.

See Also


Plugin Details

Severity: Medium

ID: 140643

File Name: ubuntu_USN-4514-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2020/09/17

Updated: 2020/11/24

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS Score Source: CVE-2020-25219

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libproxy-cil-dev, p-cpe:/a:canonical:ubuntu_linux:libproxy-dev, p-cpe:/a:canonical:ubuntu_linux:libproxy-tools, p-cpe:/a:canonical:ubuntu_linux:libproxy0.4-cil, p-cpe:/a:canonical:ubuntu_linux:libproxy1-plugin-gsettings, p-cpe:/a:canonical:ubuntu_linux:libproxy1-plugin-kconfig, p-cpe:/a:canonical:ubuntu_linux:libproxy1-plugin-mozjs, p-cpe:/a:canonical:ubuntu_linux:libproxy1-plugin-networkmanager, p-cpe:/a:canonical:ubuntu_linux:libproxy1-plugin-webkit, p-cpe:/a:canonical:ubuntu_linux:libproxy1v5, p-cpe:/a:canonical:ubuntu_linux:python-libproxy, p-cpe:/a:canonical:ubuntu_linux:python3-libproxy

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/09/17

Vulnerability Publication Date: 2020/09/09

Reference Information

CVE: CVE-2020-25219

USN: 4514-1