Ubuntu 16.04 LTS : LuaJIT vulnerability (USN-4501-1)

Medium Nessus Plugin ID 140604

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 16.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-4501-1 advisory.

- LuaJit through 2.1.0-beta3 has an out-of-bounds read because __gc handler frame traversal is mishandled.
(CVE-2020-15890)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-4501-1

Plugin Details

Severity: Medium

ID: 140604

File Name: ubuntu_USN-4501-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2020/09/15

Updated: 2020/09/15

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-15890

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libluajit-5.1-2, p-cpe:/a:canonical:ubuntu_linux:libluajit-5.1-common, p-cpe:/a:canonical:ubuntu_linux:libluajit-5.1-dev, p-cpe:/a:canonical:ubuntu_linux:luajit

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2020/09/15

Vulnerability Publication Date: 2020/07/21

Reference Information

CVE: CVE-2020-15890

USN: 4501-1