Ubuntu 16.04 LTS : Loofah vulnerability (USN-4498-1)

Low Nessus Plugin ID 140600

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 16.04 LTS host has a package installed that is affected by a vulnerability as referenced in the USN-4498-1 advisory.

- In the Loofah gem for Ruby through v2.3.0 unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished. (CVE-2019-15587)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected ruby-loofah package.

See Also

https://ubuntu.com/security/notices/USN-4498-1

Plugin Details

Severity: Low

ID: 140600

File Name: ubuntu_USN-4498-1.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2020/09/15

Updated: 2020/09/15

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2019-15587

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:ruby-loofah

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2020/09/15

Vulnerability Publication Date: 2019/10/22

Reference Information

CVE: CVE-2019-15587

USN: 4498-1