WordPress Plugin 'Email Subscribers & Newsletters' < 4.5.6 Email Forgery/Spoofing Vulnerability.

medium Nessus Plugin ID 140577
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 1.4

Synopsis

The remote WordPress application has a plugin installed that is vulnerable to an email forgery/spoofing vulnerability.

Description

The WordPress application running on the remote host has a version of the 'Email Subscribers & Newsletters' plugin that is affected by an email forgery/spoofing vulnerability in the class-es-newsletters.php class due to missing authentication for a critical function. An unauthenticated, remote attacker can exploit this via a specially crafted ajax request, to send forged email to all recipients from the available lists of contacts or subscribers, with complete control over the content and subject of the email.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the 'Email Subscribers & Newsletters' plugin to version 4.5.6 or later.

See Also

https://wordpress.org/plugins/email-subscribers/

Plugin Details

Severity: Medium

ID: 140577

File Name: wordpress_plugin_email_subscribers_4_5_6_forged_emails.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 9/14/2020

Updated: 1/4/2021

Dependencies: wordpress_plugin_detect.nbin

Risk Information

Risk Factor: Medium

VPR Score: 1.4

CVSS Score Source: CVE-2020-5780

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2020

Vulnerability Publication Date: 9/9/2020

Reference Information

CVE: CVE-2020-5780